]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: remove build host paths from installed libtool
authorShiqun Lin <Shiqun.Lin@windriver.com>
Mon, 3 Nov 2014 09:08:42 +0000 (17:08 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Nov 2014 15:36:12 +0000 (15:36 +0000)
Resulted libtool contains references about paths from the build host

Below variables contains hard coded build paths from the host:
LTCC=
lt_sysroot=
sys_lib_search_path_spec=
LD=
CC=
compiler_lib_search_dirs=
predep_objects=
postdep_objects=
compiler_lib_search_path=

Signed-off-by: Shiqun Lin <Shiqun.Lin@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/libtool/libtool_2.4.2.bb

index d3f94284d455cdaf5c2c62ff1be635adc6095e5e..60643129be204ac802711e31854c9c16dde30fb2 100644 (file)
@@ -9,6 +9,17 @@ RDEPENDS_${PN} += "bash"
 #
 SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
 
+do_install_append () {
+        sed -e 's@--sysroot=${STAGING_DIR_HOST}@@g' \
+            -e 's@${STAGING_DIR_HOST}@@g' \
+            -e 's@^\(sys_lib_search_path_spec="\).*@\1${libdir} ${base_libdir}"@' \
+            -e 's@^\(compiler_lib_search_dirs="\).*@\1${libdir} ${base_libdir}"@' \
+            -e 's@^\(compiler_lib_search_path="\).*@\1${libdir} ${base_libdir}"@' \
+            -e 's@^\(predep_objects="\).*@\1"@' \
+            -e 's@^\(postdep_objects="\).*@\1"@' \
+            -i ${D}${bindir}/libtool
+}
+
 libtool_sysroot_preprocess () {
        rm -rf ${SYSROOT_DESTDIR}${bindir}/*
        rm -rf ${SYSROOT_DESTDIR}${datadir}/aclocal/*