]> code.ossystems Code Review - openembedded-core.git/commitdiff
claws-mail: Fix building with new automake
authorJoshua Lock <josh@linux.intel.com>
Fri, 19 Mar 2010 14:59:49 +0000 (14:59 +0000)
committerJoshua Lock <josh@linux.intel.com>
Fri, 19 Mar 2010 14:59:49 +0000 (14:59 +0000)
Having the same file listed multiple times in Makefile.am breaks with new
Autotools

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/claws-mail/claws-mail.inc
meta/packages/claws-mail/files/fix-build.patch [new file with mode: 0644]

index f3208a169cdfcec4fedcc41cd6ce741824f9c10d..04401df2f51b767e0f7005518cd67750b461344e 100644 (file)
@@ -3,13 +3,14 @@ DESCRIPTION = "Mail user agent"
 #DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell openssl"
 DEPENDS = "gtk+ libetpan openssl libowl"
 LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "\
        ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2   \
        file://desktop.patch;patch=1                            \
        file://streamline-ui.patch;patch=1                              \
        file://owl-window-menu.patch;patch=1                            \
+  file://fix-build.patch;patch=1    \
        "
 
 FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
@@ -35,11 +36,12 @@ EXTRA_OECONF = "--disable-aspell-test               \
 #              --disable-libetpan              \
                --disable-gnomeprint            \
                --disable-valgrind              \
+    --disable-static    \
                "
 
 CFLAGS += "-D_GNU_SOURCE"
 
-inherit autotools_stage pkgconfig gettext
+inherit autotools pkgconfig gettext
 
 do_install_append() {
        install -d ${D}${datadir}/applications
diff --git a/meta/packages/claws-mail/files/fix-build.patch b/meta/packages/claws-mail/files/fix-build.patch
new file mode 100644 (file)
index 0000000..2f30899
--- /dev/null
@@ -0,0 +1,24 @@
+Remove duplicate file entries as this breaks install with new Automake
+
+JL 19/03/10
+
+Index: claws-mail-2.9.1/src/gtk/Makefile.am
+===================================================================
+--- claws-mail-2.9.1.orig/src/gtk/Makefile.am  2007-03-22 07:52:47.000000000 +0000
++++ claws-mail-2.9.1/src/gtk/Makefile.am       2010-03-19 14:54:06.565828281 +0000
+@@ -44,7 +44,6 @@
+       filesel.h \
+       foldersort.h \
+       gtkaspell.h \
+-      gtksctree.h \
+       gtkshruler.h \
+       gtksctree.h \
+       gtksourceprintjob.h \
+@@ -57,7 +56,6 @@
+       menu.h \
+       pluginwindow.h \
+       prefswindow.h \
+-      gtkvscrollbutton.h \
+       progressdialog.h \
+       quicksearch.h \
+       sslcertwindow.h \