]> code.ossystems Code Review - openembedded-core.git/commitdiff
external-sourcery-toolchain: ignore GNU_HASH issues with its packages
authorChristopher Larson <kergoth@gmail.com>
Mon, 21 May 2012 23:09:12 +0000 (16:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 May 2012 07:34:49 +0000 (08:34 +0100)
Signed-off-by: Christopher Larson <kergoth@gmail.com>
meta/recipes-core/meta/external-sourcery-toolchain.bb

index a14e95867d7ac76288afde303f8b1602221d85f2..b8cb6d9baf9863275e226bc6a17ff2418c9861a6 100644 (file)
@@ -92,6 +92,12 @@ PACKAGES =+ "libgcc libgcc-dev libstdc++ libstdc++-dev libstdc++-staticdev linux
 # This test should be fixed to ignore .a files in .debug dirs
 INSANE_SKIP_${PN}-dbg = "staticdev"
 
+# We don't care about GNU_HASH in prebuilt binaries
+INSANE_SKIP_${PN}-utils += "ldflags"
+INSANE_SKIP_libstdc++ += "ldflags"
+INSANE_SKIP_libgcc += "ldflags"
+INSANE_SKIP_gdbserver += "ldflags"
+
 PKG_${PN} = "eglibc"
 PKG_${PN}-dev = "eglibc-dev"
 PKG_${PN}-staticdev = "eglibc-staticdev"