]> code.ossystems Code Review - openembedded-core.git/commitdiff
jquery: use ${S}
authorJoe Slater <joe.slater@windriver.com>
Tue, 30 Jun 2020 22:17:24 +0000 (15:17 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jul 2020 15:17:01 +0000 (16:17 +0100)
Currently, several files are unpacked to WORKDIR and installed.
This makes them invisible to the archiver.  Unpack to S.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/jquery/jquery_3.5.1.bb

index b4d7e80afee605cdfdff6c60f5143fed3fee26ce..62f0dfb0c5b0fa2e93bd4a0086c85424d9487d90 100644 (file)
@@ -2,12 +2,14 @@ SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
 HOMEPAGE = "https://jquery.com/"
 LICENSE = "MIT"
 SECTION = "devel"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb"
+LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb"
 
+# unpack items to ${S} so the archiver can see them
+#
 SRC_URI = "\
-    https://code.jquery.com/${BP}.js;name=js \
-    https://code.jquery.com/${BP}.min.js;name=min \
-    https://code.jquery.com/${BP}.min.map;name=map \
+    https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
+    https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
+    https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
     "
 
 SRC_URI[js.sha256sum] = "416a3b2c3bf16d64f6b5b6d0f7b079df2267614dd6847fc2f3271b4409233c37"
@@ -20,9 +22,9 @@ inherit allarch
 
 do_install() {
     install -d ${D}${datadir}/javascript/${BPN}/
-    install -m 644 ${WORKDIR}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
-    install -m 644 ${WORKDIR}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
-    install -m 644 ${WORKDIR}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
+    install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
+    install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
+    install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
 }
 
 PACKAGES = "${PN}"