]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-yocto: inhibit BSP description warnings for custom linux-yocto kernels
authorBruce Ashfield <bruce.ashfield@windriver.com>
Mon, 2 Mar 2015 21:36:39 +0000 (16:36 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 2 Mar 2015 22:05:02 +0000 (22:05 +0000)
We don't require that a yocto custom kernel + defconfig have a full BSP
description (but of course it would be better if they did). Since this
isn't a requirement, we shouldn't alarm users by generating a BSP
description warning.

To implement this, we add a bsp audit level flag (like the one that
exists for kconfig audits), and only set it to activate in the versioned
linux-yocto recipes.

[YOCTO: #7370]

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel-yocto.bbclass
meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
meta/recipes-kernel/linux/linux-yocto.inc
meta/recipes-kernel/linux/linux-yocto_3.14.bb
meta/recipes-kernel/linux/linux-yocto_3.19.bb

index c8d1e95df3480d872f6df634582e2800e0673b76..8db489964ed2d2bef1319b8637ca9c3f3608b1f7 100644 (file)
@@ -265,6 +265,7 @@ python do_kernel_configcheck() {
     ret, result = oe.utils.getstatusoutput("%s%s" % (pathprefix, cmd))
 
     config_check_visibility = int(d.getVar( "KCONF_AUDIT_LEVEL", True ) or 0)
+    bsp_check_visibility = int(d.getVar( "KCONF_BSP_AUDIT_LEVEL", True ) or 0)
 
     # if config check visibility is non-zero, report dropped configuration values
     mismatch_file = "${S}/" + kmeta + "/" + "mismatch.cfg"
@@ -283,13 +284,13 @@ python do_kernel_configcheck() {
                 bb.warn( "[kernel config]: BSP specified non-hw configuration:\n\n%s" % results)
 
     bsp_desc = "${S}/" + kmeta + "/" + "top_tgt"
-    if os.path.exists(bsp_desc):
+    if os.path.exists(bsp_desc) and bsp_check_visibility > 1:
         with open (bsp_desc, "r") as myfile:
-                bsp_tgt = myfile.read()
-                m = re.match("^(.*)scratch.obj(.*)$", bsp_tgt)
-                if not m is None:
-                    bb.warn( "[kernel]: An auto generated BSP description was used, this normally indicates a misconfiguration.\n" +
-                             "Check that your machine (%s) has an associated kernel description." % "${MACHINE}" )
+            bsp_tgt = myfile.read()
+            m = re.match("^(.*)scratch.obj(.*)$", bsp_tgt)
+            if not m is None:
+                bb.warn( "[kernel]: An auto generated BSP description was used, this normally indicates a misconfiguration.\n" +
+                         "Check that your machine (%s) has an associated kernel description." % "${MACHINE}" )
 }
 
 # Ensure that the branches (BSP and meta) are on the locations specified by
index 8e2189654bc5084fc55726d6da490168e56a8a40..bd61c4a927c8b5a0a153eb2db7afa0d7d4ebf2cc 100644 (file)
@@ -14,6 +14,7 @@ LINUX_VERSION ?= "3.14.29"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
 
 LINUX_KERNEL_TYPE = "preempt-rt"
 
index db9ad738c3ab1664d2d31beb1ab84465ee2e66ce..d110297246c1f9ecfbfdba1d4d3c25a28fd7c263 100644 (file)
@@ -7,6 +7,7 @@ require recipes-kernel/linux/linux-yocto.inc
 LINUX_VERSION ?= "3.14.29"
 
 KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "f65678ef48c5d41af914d2769e4dd01411c1df96"
 SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
index 1997e30a25892454d01bd0c3216201e42400b650..d10449aab365ef192c865e3b822fc19500b4c38d 100644 (file)
@@ -7,6 +7,7 @@ require recipes-kernel/linux/linux-yocto.inc
 LINUX_VERSION ?= "3.19"
 
 KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "43b9eced9ba8a57add36af07736344dcc383f711"
 SRCREV_meta ?= "f7a81274b461d0c748964d75c24bea8574d350fb"
index 79b3f256f4bcc33c7b63203109b9096b62dcf2f4..c62f8ca97de492e0bd754dea89c1508773be336b 100644 (file)
@@ -28,6 +28,7 @@ SRCREV_FORMAT ?= "meta_machine"
 #   1: report options that are specified, but not in the final config
 #   2: report options that are not hardware related, but set by a BSP
 KCONF_AUDIT_LEVEL ?= "1"
+KCONF_BSP_AUDIT_LEVEL ?= "0"
 
 LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
 
index ac0143089795965d64593ddf8f3f40ebeb277d11..9cdd3eea0d5c1276af23a7e6793d3b4438b6cf61 100644 (file)
@@ -28,6 +28,7 @@ LINUX_VERSION ?= "3.14.29"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
 
 COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
 
index f856d19f938ff4d0df66f91894dab20c05fbba36..f1bf3bea9016fcce2f2b2f274725d2bbf62afd4e 100644 (file)
@@ -28,6 +28,7 @@ LINUX_VERSION ?= "3.19"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 KMETA = "meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
 
 COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"