]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: fix QA issue
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 17 Oct 2018 19:03:28 +0000 (19:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2018 09:38:57 +0000 (10:38 +0100)
ERROR: systemtap-4.0-r0 do_package: QA Issue: systemtap:
Files/directories were installed but not shipped in any package:
  /lib
  /lib/systemd
  /lib/systemd/system
  /lib/systemd/system/stap-exporter.service
Please set FILES such that these items are packaged. Alternatively if
they are unneeded, avoid installing them or delete them within
do_install.
systemtap: 4 installed and not shipped files. [installed-vs-shipped]

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/systemtap/systemtap_git.bb

index 78a82efc2c3c637a294b9c00c7db0ed833f5e323..904ecdd10622669469dea9758912c0967e1b7030 100644 (file)
@@ -27,6 +27,8 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
 
 inherit autotools gettext pkgconfig distutils3-base systemd
 
+SYSTEMD_SERVICE_${PN} = "stap-exporter.service"
+
 do_configure_prepend () {
     # Improve reproducibility for c++ object files
     reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}"