]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: enable dri in native/nativesdk through gallium drivers
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 2 Apr 2021 20:46:27 +0000 (22:46 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Apr 2021 14:27:24 +0000 (15:27 +0100)
Previously, dri was enabled via a token dri driver (swrast, then
nouveau). Upstream is discussing removing dri drivers altogether
(they're becoming difficult to support and only needed for obsolete
x86 hardware), so let's prepare for that happening in the future:

https://lists.freedesktop.org/archives/mesa-dev/2021-March/224984.html

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa.inc
meta/recipes-graphics/mesa/mesa_21.0.1.bb

index d7f34739de05acc9fea3b3b437f3f26ff5c6dcda..caf3c62ad8b4b3a54e6f8fb44680f71ec7d9f32c 100644 (file)
@@ -87,8 +87,8 @@ PACKAGECONFIG_class-target ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland v
                    ${@bb.utils.contains('DISTRO_FEATURES', 'x11 vulkan', 'dri3', '', d)} \
                    elf-tls \
                   "
-PACKAGECONFIG_class-native ?= "gbm dri egl opengl elf-tls x11"
-PACKAGECONFIG_class-nativesdk ?= "gbm dri egl opengl elf-tls x11"
+PACKAGECONFIG_class-native ?= "gbm gallium egl opengl elf-tls x11"
+PACKAGECONFIG_class-nativesdk ?= "gbm gallium egl opengl elf-tls x11"
 
 PACKAGECONFIG_remove_libc-musl = "elf-tls"
 
index d578c75e3939aabcc27217075185e8710355b376..8c584d8e9fe6c073f7057b1ea421410a93593ee5 100644 (file)
@@ -1,6 +1,4 @@
 require ${BPN}.inc
 
-DRIDRIVERS_class-native = "nouveau"
-DRIDRIVERS_class-nativesdk = "nouveau"
 DRIDRIVERS_append_x86_class-target = ",r100,r200,nouveau,i965,i915"
 DRIDRIVERS_append_x86-64_class-target = ",r100,r200,nouveau,i965,i915"