]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Remove MACHINE reference in do_configure, it causes perl to be rebuild many...
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 26 Jan 2011 10:02:31 +0000 (10:02 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 26 Jan 2011 11:37:31 +0000 (11:37 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl_5.12.2.bb

index 9137b401a5c43e58fc0382371b3d6a7360198d26..e7e1cb4dd46fb8dbb195c798533851d9eb34a3d7 100644 (file)
@@ -139,13 +139,11 @@ do_configure() {
               -e 's,/perl5,/perl,g' \
             config.sh-${TARGET_ARCH}-${TARGET_OS}
 
-        if test "${MACHINE}" != "native"; then
-            # These are strewn all over the source tree
-            for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
-                echo Fixing: $foo
-                sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
-            done
-        fi
+        # These are strewn all over the source tree
+        for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+            echo Fixing: $foo
+            sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
+        done
 
         rm -f config
         echo "ARCH = ${TARGET_ARCH}" > config