]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi: enable service when using systemd
authorKoen Kooi <koen@dominion.thruhere.net>
Wed, 1 Jun 2011 14:27:31 +0000 (16:27 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jun 2011 13:47:26 +0000 (14:47 +0100)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-connectivity/avahi/avahi.inc
meta/recipes-connectivity/avahi/avahi_0.6.30.bb

index 099c5a4c2df3f0f1c59aa76ca14f6ca757122869..9e26a20f22df69cb8771206e41324fcc280e856d 100644 (file)
@@ -46,6 +46,24 @@ PACKAGES =+ "avahi-systemd avahi-daemon libavahi-common libavahi-core libavahi-c
 FILES_avahi-systemd = "${base_libdir}/systemd"
 RDEPENDS_avahi-systemd = "avahi-daemon"
 
+pkg_postinst_avahi-systemd() {
+       # can't do this offline
+       if [ "x$D" != "x" ]; then
+               exit 1
+       fi
+       
+       systemctl enable avahi-daemon.service
+}
+
+pkg_postrm_avahi-systemd() {
+       # can't do this offline
+       if [ "x$D" != "x" ]; then
+               exit 1
+       fi
+
+       systemctl disable avahi-daemon.service
+}
+
 FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
 FILES_libavahi-core = "${libdir}/libavahi-core.so.*"
 FILES_libavahi-ui = "${libdir}/libavahi-ui.so.*"
index e63f40645e3e48a89bcca70b95cea47b5204848e..23c0fa0533de00ab4f2c429e4d196014a613814f 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
                     file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
 
 RDEPENDS_avahi-daemon = "sysvinit-pidof"
-PR = "r1"
+PR = "r3"
 
 EXTRA_OECONF += "--disable-gtk3"