]> code.ossystems Code Review - openembedded-core.git/commitdiff
gst-plugins-base: element selection rationalisation
authorRoss Burton <ross.burton@intel.com>
Mon, 24 Jun 2013 10:26:27 +0000 (11:26 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Jun 2013 16:43:42 +0000 (17:43 +0100)
Use PACKAGECONFIG to control the X11 elements, and add statements for the
elements that we don't always enable.

Remove the freetype dependency as it's apparently (but not really) only needed
by the examples.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bb

index 462c54d8168eacbbd05b5e673424ec686ae99365..26c562c05c5750c3c57e096714852602ac593621 100644 (file)
@@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
                     file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
                     file://gst/ffmpegcolorspace/utils.c;beginline=1;endline=20;md5=9c83a200b8e597b26ca29df20fc6ecd0"
 
-DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxv libsm libice', '', d)}"
-DEPENDS += "alsa-lib freetype liboil libogg libvorbis libtheora util-linux tremor"
+DEPENDS += "alsa-lib liboil libogg libvorbis libtheora util-linux tremor"
 
 SRC_URI += "file://gst-plugins-base-tremor.patch \
             file://configure.ac-fix-subparse-plugin.patch"
@@ -19,7 +18,14 @@ PR = "r7"
 
 inherit gettext
 
-EXTRA_OECONF += "--disable-freetypetest --disable-pango --disable-gnome_vfs --disable-orc"
+EXTRA_OECONF += "--disable-freetypetest"
+
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+PACKAGECONFIG[gnomevfs] = "--enable-gnome_vfs,--disable-gnome_vfs,gnome-vfs"
+PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
+PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
+PACKAGECONFIG[x11] = "--enable-x --enable-xvideo,--disable-x --disable-xvideo,virtual/libx11 libxv libsm libice"
 
 do_configure_prepend() {
        # This m4 file contains nastiness which conflicts with libtool 2.2.2