]> code.ossystems Code Review - openembedded-core.git/commitdiff
libzypp: fix for non /usr/lib libdir case
authorYu Ke <ke.yu@intel.com>
Wed, 13 Jul 2011 08:58:27 +0000 (16:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 13 Jul 2011 11:14:12 +0000 (12:14 +0100)
this patch has two fixes:
1. the src tool/CMakeLists.txt has hardcode "lib", so add a patch to fix it
2. the recipe has hardcode "-DLIB=lib", so replace it with libdir

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch [new file with mode: 0644]
meta/recipes-extended/libzypp/libzypp_git.bb

diff --git a/meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch b/meta/recipes-extended/libzypp/libzypp/hardcode-lib-fix.patch
new file mode 100644 (file)
index 0000000..c11f5c5
--- /dev/null
@@ -0,0 +1,22 @@
+tools/CMakeLists.txt: replace the hardcode "lib"
+
+replace the hardcode "lib" with LIB_INSTALL_DIR
+this will work with non /usr/lib libdir case
+
+Upstream-Status: Pending
+
+Signed-off-by: Yu Ke <ke.yu@intel.com>
+
+Index: libzypp/tools/CMakeLists.txt
+===================================================================
+--- libzypp.orig/tools/CMakeLists.txt
++++ libzypp/tools/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ ADD_SUBDIRECTORY( package-manager )
+-INSTALL( FILES notify-message DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/zypp" )
++INSTALL( FILES notify-message DESTINATION "${LIB_INSTALL_DIR}/zypp" )
+ ## ############################################################
index 824f7a1339d39fb8b0cfce89afef700200e9ff44..6555bd40442a8b6bdca0bd356ffa0d94afaab673 100644 (file)
@@ -14,7 +14,7 @@ RDEPENDS_${PN} = "sat-solver"
 S = "${WORKDIR}/git"
 SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
 PV = "0.0-git${SRCPV}"
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
            file://no-doc.patch \
@@ -23,6 +23,7 @@ SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
           file://config-release.patch \
           file://libzypp-pokyarch.patch \
           file://fix_for_compile_wth_gcc-4.6.0.patch \
+          file://hardcode-lib-fix.patch \
           "
 
 SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"
@@ -33,7 +34,7 @@ SRC_URI_append_arm  = " file://arm-workaround-global-constructor.patch"
 FILES_${PN} += "${libdir}/zypp ${datadir}/zypp ${datadir}/icons"
 FILES_${PN}-dev += "${datadir}/cmake"
 
-EXTRA_OECMAKE += "-DLIB=lib"
+EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"