]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: mkdir ${B} -> mkdir -p ${B}
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 16 Sep 2015 10:25:00 +0000 (03:25 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Sep 2015 21:17:19 +0000 (22:17 +0100)
${B} is the default cwd of tasks, so there might be race issues such as:
| mkdir: cannot create directory `/path/to/work/qemux86-poky-linux/perf/1.0-r9/perf-1.0/': File exists
[snip]
NOTE: recipe perf-1.0-r9: task do_configure: Failed

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 241cca97f063094dbc8d58aadb4137acfa9188eb..22bd3c820055d2c23b600464f77140d0279a6b53 100644 (file)
@@ -120,7 +120,7 @@ do_install() {
 do_configure_prepend () {
     # Fix for rebuilding
     rm -rf ${B}/
-    mkdir ${B}/
+    mkdir -p ${B}/
 
     # If building a multlib based perf, the incorrect library path will be
     # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit