]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: add PACKAGECONFIG option to use libssh2
authorFabrice Coulon <fabrice@axis.com>
Fri, 3 Oct 2014 08:21:49 +0000 (10:21 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Oct 2014 09:39:12 +0000 (10:39 +0100)
The user can enable libssh2 via conf/local.conf or custom distro
configuration, this will pull in libssh2, which is not used by default.

For example, a curl_x.y.z.bbappend file containing the following line:
PACKAGECONFIG += "libssh2"

Signed-off-by: Fabrice Coulon <fabrice.coulon@axis.com>
Signed-off-by: Olof Johansson <olof.johansson@axis.com>
meta/recipes-support/curl/curl_7.37.1.bb

index e2852e39a5994be07cce1e48d1a8e7d051ae6d30..39ded80190951b62ea6fad3561d2d01fbbf492e7 100644 (file)
@@ -28,9 +28,9 @@ PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openss
 PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
 PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
 PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
+PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
 
-EXTRA_OECONF = "--without-libssh2 \
-                --without-libidn \
+EXTRA_OECONF = "--without-libidn \
                 --enable-crypto-auth \
                 --disable-ldap \
                 --disable-ldaps \