]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: fix qemu ptest cannot work
authorChangqing Li <changqing.li@windriver.com>
Wed, 12 Jun 2019 07:09:21 +0000 (15:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Jun 2019 20:08:13 +0000 (21:08 +0100)
do_install_ptest in recipe is covered by default function
in ptest.bbclass since inherit ptest write in wrong place,
fix it by move it to top.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemu.inc

index e44e351129dff182feb7d2f1045f59bfa4ecc669..ac475a8e2ae34be410cd5f8717caa29cdd1e16fe 100644 (file)
@@ -4,6 +4,9 @@ LICENSE = "GPLv2 & LGPLv2.1"
 
 RDEPENDS_${PN}-ptest = "bash make"
 
+require qemu-targets.inc
+inherit pkgconfig bluetooth ptest
+
 LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
                     file://COPYING.LIB;endline=24;md5=8c5efda6cf1e1b03dcfd0e6c0d271c7f"
 
@@ -49,10 +52,6 @@ do_install_ptest() {
               -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
 }
 
-
-require qemu-targets.inc
-inherit pkgconfig bluetooth ptest
-
 # QEMU_TARGETS is overridable variable
 QEMU_TARGETS ?= "arm aarch64 i386 mips mipsel mips64 mips64el ppc riscv32 riscv64 sh4 x86_64"