]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: fix installed but not shipped issue
authorKang Kai <kai.kang@windriver.com>
Wed, 16 Jan 2013 09:54:42 +0000 (17:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Jan 2013 11:12:42 +0000 (11:12 +0000)
It shows warning when bitbake perl:
WARNING: QA Issue: perl: Files/directories were installed but not
shipped
  /usr/lib/perl/5.14.2/auto/XS/Typemap

That because file Typemap.so is not install correctly. Fix it.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-tests.inc
meta/recipes-devtools/perl/perl_5.14.2.bb

index e6de0887698fa0ef70e054d6b9c2d023e668e292..b97b46781d3a7738b65ccccf7af21d7ff1b36c28 100644 (file)
@@ -25,6 +25,7 @@ do_install_append () {
        cp -pv lib/XS/Typemap.pm ${D}${libdir}/perl/${PV}/XS/
        mkdir -p ${D}${libdir}/perl/${PV}/auto/XS/APItest
        cp -pv lib/auto/XS/APItest/APItest.so ${D}${libdir}/perl/${PV}/auto/XS/APItest/
+       mkdir -p ${D}${libdir}/perl/${PV}/auto/XS/Typemap
        cp -pv lib/auto/XS/Typemap/Typemap.so ${D}${libdir}/perl/${PV}/auto/XS/Typemap/
        cp -pv cpan/Digest-MD5/README ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
        cp -pv cpan/Digest-MD5/MD5.xs ${D}${PERL_TEST_DIR}/cpan/Digest-MD5/
index e62e8ec657085e5862ec5143616e76ec71f7b48a..f924ebd6d050b24b5afcf1916be9e85b1bf4a017 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db grep-native"
 DEPENDS += "gdbm zlib"
-PR = "r17"
+PR = "r18"
 
 # 5.10.1 has Module::Build built-in
 PROVIDES += "libmodule-build-perl"