]> code.ossystems Code Review - openembedded-core.git/commitdiff
trace-cmd: fix recompile error
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 7 Aug 2014 13:40:55 +0000 (06:40 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 10:20:49 +0000 (11:20 +0100)
Fixed:
make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `parse-events.o'.  Stop.
make: *** Waiting for unfinished jobs....
ERROR: oe_runmake failed

This happens when upgrade gcc from 4.9.0 to 4.9.1, and the
.parse-events.d isn't regenerated when recompile, the content of it are:

[snip]
parse-events.o: /path/to/sysroot/4.9.0/include/stddef.h
[snip]

And Makefile includes the .parse-events.d file if it exists, so there
would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't
exist.

Remove .*.d (a few .d files, its Makefile uses this wildcard) will fix
the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/trace-cmd/trace-cmd_2.3.2.bb

index 8d26205672d2d58b34ebd36e338795cfe9e3d35e..a4d5382aaf2b265418bee4c634df51f5c6c4de96 100644 (file)
@@ -30,6 +30,11 @@ EXTRA_OEMAKE = "\
 
 FILES_${PN}-dbg += "${libdir}/trace-cmd/plugins/.debug"
 
+do_compile_prepend() {
+    # Make sure the recompile is OK
+    rm -f ${B}/.*.d
+}
+
 do_install() {
         oe_runmake DESTDIR="${D}" install
 }