]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.8: qemuarm boot fix
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 26 Mar 2013 14:46:38 +0000 (07:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Mar 2013 17:49:32 +0000 (17:49 +0000)
The preempt-rt kernel was wasn't inheriting the standard kernel
configuration and hence was not able to boot on qemuarm due to
missing ABI options.

Changing the main preempt-rt kernel include to inherit standard
configuration again fixes this boot issue.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_3.8.bb
meta/recipes-kernel/linux/linux-yocto_3.8.bb

index f12de2e9740f8cd0667834fa7318fd432b1e5b45..255e2e37b49f839a49022590a7ddc4d676d4b7a3 100644 (file)
@@ -8,9 +8,9 @@ LINUX_KERNEL_TYPE = "preempt-rt"
 
 KMETA = "meta"
 
-SRCREV_machine ?= "d125901ac3e516e9b894df088f4282347651b690"
-SRCREV_machine_qemuppc ?= "66630413d6df1665f2c5c94d25eb409271ffe20c"
-SRCREV_meta ?= "2a6d36e75ca0a121570a389d7bab76ec240cbfda"
+SRCREV_machine ?= "f35992f80c81dc5fa1a97165dfd5cbb84661f7cb"
+SRCREV_machine_qemuppc ?= "5789e3f33c1d5df35ced60d0153cafca7cd0e319"
+SRCREV_meta ?= "1b534b2f8bbe9b8a773268cfa30a4850346f6f5f"
 
 PR = "${INC_PR}.0"
 PV = "${LINUX_VERSION}+git${SRCPV}"
index f2ad0e5dd6f170de7dbaeeea4477246c31e9792a..95a4906b9929503d79d64bfc182114bab7d92f53 100644 (file)
@@ -9,7 +9,7 @@ SRCREV_machine_qemuppc ?= "8844013c81e9ad80246aabca6573eed9dbaac646"
 SRCREV_machine_qemux86 ?= "15a0766b3d007e5fafce3503375694dff2b0603e"
 SRCREV_machine_qemux86-64 ?= "15a0766b3d007e5fafce3503375694dff2b0603e"
 SRCREV_machine ?= "15a0766b3d007e5fafce3503375694dff2b0603e"
-SRCREV_meta ?= "2a6d36e75ca0a121570a389d7bab76ec240cbfda"
+SRCREV_meta ?= "1b534b2f8bbe9b8a773268cfa30a4850346f6f5f"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"