]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-kdrive-common: run calibration only on machines with touchscreen
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 11 Jun 2007 07:37:03 +0000 (07:37 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 11 Jun 2007 07:37:03 +0000 (07:37 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1904 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xserver-kdrive-common/xserver-kdrive-common/etc/X11/Xsession.d/30xTs_Calibrate
meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb

index 8e6a8b22cb9b2f94ed55ae3067d1b3b0d456e6e7..ee55784548e32321992d3b9c66223dbcf641f024 100644 (file)
@@ -1,6 +1,10 @@
 #!/bin/sh
 
-while [ ! -z $TSLIB_TSDEVICE ] && [ ! -f /etc/pointercal ]
-do
-   /usr/bin/xtscal
-done
+. /etc/formfactor/config
+
+if [ "$HAVE_TOUCHSCREEN" = "1" ]; then
+       while [ ! -z $TSLIB_TSDEVICE ] && [ ! -f /etc/pointercal ]
+       do
+          /usr/bin/xtscal
+       done
+fi
index dff4b509a4bde95a07df52734613af973870316e..dcbea4a2ee05e21e7968f6f6c60b32d3f080d435 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit formfactor"
-PR = "r17"
+PR = "r18"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
@@ -15,4 +15,4 @@ do_install() {
        rm -fR ${D}/etc/*/.svn
        rm -fR ${D}/etc/*/*/.svn
        chmod -R 755 ${D}/etc
-}
\ No newline at end of file
+}