]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-yocto.bbclass: ensure repatching when HEAD is checked out
authorAwais Belal <awais_belal@mentor.com>
Tue, 14 Feb 2017 21:14:15 +0000 (16:14 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 19 Feb 2017 14:16:50 +0000 (06:16 -0800)
In some cases it is seen that kernel_checkout and validate_branches are
run again in simultaneous builds. During do_patch the kgit-s2q mechanism
looks for a sentinel file inside the .git directory, finds a fence post
and starts picking up patches after that.

This can create trouble as validate_branches checks out the HEAD of the
branch and so the patches should be reapplied rather than skipped due to
finding of the fence post.

We can call kgit-s2q --clean to remove the sentinel file when the
branches are checked out.

Signed-off-by: Awais Belal <awais_belal@mentor.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel-yocto.bbclass
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb

index a7b635638186c0e5f16ea48a107fc9cd03c9028f..33361b962469f23d806fa3356da0d4cfc70d31ae 100644 (file)
@@ -365,6 +365,10 @@ do_validate_branches() {
                        current_branch=`git rev-parse --abbrev-ref HEAD`
                        git branch "$current_branch-orig"
                        git reset --hard ${force_srcrev}
+                       # We've checked out HEAD, make sure we cleanup kgit-s2q fence post check
+                       # so the patches are applied as expected otherwise no patching
+                       # would be done in some corner cases.
+                       kgit-s2q --clean
                fi
        fi
 }
index 4b1de5752c93fa7b421bb1a05aeab5ae18bc26d4..03f8ce3cc253c7f3e3bdf6cbd9786fcb9470e7cf 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=a6c2fa8aef1b
 
 DEPENDS = "git-native"
 
-SRCREV = "c14440d4e7ae0160c260ed65c3e123be5dc97ae8"
+SRCREV = "5deada879404820db146685729e89ba0887fc0ee"
 PR = "r12"
 PV = "0.2+git${SRCPV}"