]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: fix build race under musl
authorRoss Burton <ross.burton@intel.com>
Wed, 29 Nov 2017 12:31:55 +0000 (12:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 9 Dec 2017 14:36:58 +0000 (14:36 +0000)
Under musl bash uses its own libintl clone but there are some missing
dependencies so it is possible for pathexp.o to be built whilst libintl.h is
being written, leading to compile errors.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/bash/bash/pathexp-dep.patch [new file with mode: 0644]
meta/recipes-extended/bash/bash_4.4.bb

diff --git a/meta/recipes-extended/bash/bash/pathexp-dep.patch b/meta/recipes-extended/bash/bash/pathexp-dep.patch
new file mode 100644 (file)
index 0000000..e05bbda
--- /dev/null
@@ -0,0 +1,13 @@
+pathexp includes libintl.h but doesn't depend on it, thus a build race can occur.
+
+Upstream-Status: Submitted (https://savannah.gnu.org/patch/index.php?9503)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.in b/Makefile.in
+index c7b62bc0..241cbf12 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1281,2 +1281,3 @@ nojobs.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
+ y.tab.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
++pathexp.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
+ pcomplete.o: bashintl.h ${LIBINTL_H} $(BASHINCDIR)/gettext.h
index e544d07c10edb817524632999bf9197a464836b4..8b989ed3bd87f5d6de85a61ab99738c6404b6b88 100644 (file)
@@ -26,6 +26,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
            file://fix-run-builtins.patch \
            file://0001-help-fix-printf-format-security-warning.patch \
            file://bash-memleak-bug-fix-for-builtin-command-read.patch \
+           file://pathexp-dep.patch \
            "
 
 SRC_URI[tarball.md5sum] = "148888a7c95ac23705559b6f477dfe25"