]> code.ossystems Code Review - openembedded-core.git/commitdiff
go-dep: upgrade 0.3.1 -> 0.3.2
authorOtavio Salvador <otavio@ossystems.com.br>
Wed, 17 Jan 2018 15:59:32 +0000 (13:59 -0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Jan 2018 16:35:08 +0000 (16:35 +0000)
The 0.3.2 version has been released in Oct 19, 2017, and has a great
set of features and improvements, as seen in the announcement summary:

,----
| NEW FEATURES:
|
| - Add support for importing from gvt and gb. (#1149)
| - Wildcard ignore support. (#1156)
| - Disable SourceManager lock by setting DEPNOLOCK environment
|   variable.  (#1206)
| - dep ensure -no-vendor -dry-run now exits with an error when
|   changes would have to be made to Gopkg.lock. This is useful
|   for CI. (#1256)
|
| BUG FIXES:
|
| - gps: Fix case mismatch error with multiple dependers. (#1233)
| - Skip broken vendor symlink rather than returning an error. (#1191)
| - Fix status shows incorrect reason for lock mismatch when ignoring
|   packages. (#1216)
|
| IMPROVEMENTS:
|
| - Allow dep ensure -add and -update when lock is out-of-sync. (#1225)
| - gps: vcs: Dedupe git version list (#1212)
| - gps: Add prune functions to gps. (#1020)
| - gps: Skip broken vendor symlinks. (#1191)
| - dep ensure -add now concurrently fetches the source and adds the
|   projects. (#1218)
| - File name case check is now performed on Gopkg.toml and Gopkg.lock.
|   (#1114)
| - gps: gps now supports pruning. (#1020)
| - dep ensure -update now concurrently validates the passed project
|   arguments. Improving performance when updating dependencies with
|   -update. (#1175)
| - dep status now concurrently fetches repo info. Improving status
|   performance. (#1135)
| - gps: Add SourceURLsForPath() to SourceManager. (#1166)
| - gps: Include output in error. (#1180)
`----

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/go/go-dep_0.3.2.bb [moved from meta/recipes-devtools/go/go-dep_0.3.1.bb with 88% similarity]

similarity index 88%
rename from meta/recipes-devtools/go/go-dep_0.3.1.bb
rename to meta/recipes-devtools/go/go-dep_0.3.2.bb
index 3a404e357f5d990e63dd66ab3960e81826523af7..627324a1df73b8805be5e0a91ad31128a88d916a 100644 (file)
@@ -9,8 +9,8 @@ SRC_URI = "git://${GO_IMPORT} \
            file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
           "
 
-# Points to 0.3.1 tag
-SRCREV = "83789e236d7ff64c82ee8392005455fc1ec1983b"
+# Points to 0.3.2 tag
+SRCREV = "8ddfc8afb2d520d41997ebddd921b52152706c01"
 
 inherit go