]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-demos: Build with system data files
authorDrew Moseley <drew_moseley@mentor.com>
Tue, 3 Jun 2014 00:23:36 +0000 (20:23 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jun 2014 08:17:15 +0000 (09:17 +0100)
Use the "--with-system-data-files" when configuring mesa-demos
so that the data files in /usr/share/mesa-demos/ will be properly
located at run time.

Copy some additional data files into the target filesystem.

Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb

index 7cda19eb6fa65c4a4d7a72f9669dcaa13b72b342..972ead347812d2237ad8c053ab507d9c49035014 100644 (file)
@@ -27,6 +27,8 @@ PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
 # The Wayland code doesn't work with Wayland 1.0, so disable it for now
 #${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
 
+EXTRA_OECONF = "--with-system-data-files"
+
 PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
 PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
 PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
@@ -38,3 +40,12 @@ PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
 PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
 PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
 PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
+
+do_install_append () {
+    install -m 0644 ${S}/src/perf/*.frag \
+                    ${S}/src/perf/*.vert \
+                    ${S}/src/glsl/*.frag \
+                    ${S}/src/glsl/*.vert \
+                    ${S}/src/glsl/*.geom \
+                    ${S}/src/glsl/*.glsl ${D}${datadir}/${BPN}
+}