]> code.ossystems Code Review - openembedded-core.git/commitdiff
ldconfig/cdrtools/icecc-create-env/linuxdoc-tools/python: Set FILESPATH to find ...
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Nov 2012 22:16:22 +0000 (22:16 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Nov 2012 16:54:19 +0000 (16:54 +0000)
In a small number of cases we need to have ${PN} in FILESPATH rather
than ${BPN}. Rather than hurt readability for all other recipes,
set FILESPATH in these recipes so we can prune the default.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/eglibc/ldconfig-native_2.12.1.bb
meta/recipes-devtools/cdrtools/cdrtools-native_2.01.bb
meta/recipes-devtools/icecc-create-env/icecc-create-env-native_0.1.bb
meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
meta/recipes-devtools/python/python-native_2.7.3.bb

index 2a939132b8c76db97f1a7ea6e92ed61a560a267b..63ef95b7e7add57402adb71cc5f8b858e0f5863b 100644 (file)
@@ -14,6 +14,8 @@ SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
 
 PR = "r2"
 
+FILESPATH = "${FILE_DIRNAME}/${PN}-${PV}/"
+
 inherit native
 
 S = "${WORKDIR}/${PN}-${PV}"
index 9068771bc424f7acf7b6af131cab27b67e978faa..fc479774d93d44f54ff5a3b1c3ee0e0acb97390b 100644 (file)
@@ -20,6 +20,8 @@ inherit native
 
 STAGE_TEMP = "${WORKDIR}/image-temp"
 
+FILESPATH = "${FILE_DIRNAME}/cdrtools-native/"
+
 do_install() {
        install -d ${STAGE_TEMP}
        make install INS_BASE=${STAGE_TEMP}
index 7db39781eef6ffdfbd95741f88126def82b2f64e..b04474efcb65746fcd3e75d28d8428a576bfa498 100644 (file)
@@ -11,6 +11,8 @@ PR = "r2"
 DEPENDS = ""
 INHIBIT_DEFAULT_DEPS = "1"
 
+FILESPATH = "${FILE_DIRNAME}/${PN}/"
+
 inherit native
 
 PATCHTOOL = "patch"
index fafa42194d37c1ad3240409e2a943c247408c44b..5c9dd6f5dab70cc609859ed9286c25ceec9e012b 100644 (file)
@@ -17,6 +17,8 @@ SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.tar.gz \
 SRC_URI[md5sum] = "f214e79b0dd084689cd04f18722bd563"
 SRC_URI[sha256sum] = "128cabb52ef8fb2f370ee488ea92bf4d8e49859200c7c8cae807abfe860a62ec"
 
+FILESPATH = "${FILE_DIRNAME}/linuxdoc-tools-native/"
+
 inherit autotools native
 
 do_configure () {
index b0b3503ed92e3a2d4d609f95620260732dfe966f..162ecedb73cded5bb01058456dbe1c51b1653388 100644 (file)
@@ -19,6 +19,8 @@ SRC_URI += "file://04-default-is-optimized.patch \
            "
 S = "${WORKDIR}/Python-${PV}"
 
+FILESPATH = "${FILE_DIRNAME}/python-native/:${FILE_DIRNAME}/python/"
+
 inherit native
 
 RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native"