]> code.ossystems Code Review - openembedded-core.git/commitdiff
bitbake-dev: Don't fallback if the UI fails to start; give an error message on UI...
authorRobert Bradford <rob@openedhand.com>
Fri, 17 Oct 2008 09:47:08 +0000 (09:47 +0000)
committerRobert Bradford <rob@openedhand.com>
Fri, 17 Oct 2008 09:47:08 +0000 (09:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5530 311d38ba-8fff-0310-9ca6-ca027cbcb966

bitbake-dev/bin/bitbake

index ea4147e97158206ccb6be0fc64dd203e3b45b5cb..1f650e2bdcfb0ae1c889db50984e76872667cc63 100755 (executable)
@@ -167,12 +167,6 @@ Default BBFILES are the .bb files in the current directory.""" )
 
     # Launch the UI
     try:
-        if curseUI:
-            try:
-                import curses
-            except ImportError, details:
-                curseUI = False
-
         if curseUI:
             from bb.ui import ncurses
             ncurses.init(server, eventHandler)
@@ -182,7 +176,8 @@ Default BBFILES are the .bb files in the current directory.""" )
         else:
             from bb.ui import knotty
             return_value = knotty.init(server, eventHandler)
-
+    except Exception, e:
+       print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e.message)
     finally:
         # Don't wait for server indefinitely
         import socket