]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconf: don't use alternatives
authorRoss Burton <ross.burton@intel.com>
Tue, 11 Sep 2018 09:37:45 +0000 (10:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Sep 2018 09:46:12 +0000 (10:46 +0100)
There's no need to do alternatives as pkgconf and pkg-config won't be installed
at the same time, and pkg-config doesn't do alternatives either.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pkgconf/pkgconf_1.5.3.bb

index 2021d1ac6022d13180b90ca4cc12f3da50bab732..415478d5cf9c2ad4cc5544c439f48e217e2376fa 100644 (file)
@@ -24,7 +24,7 @@ SRC_URI = "\
 SRC_URI[md5sum] = "c21743bca14c882c0f282746168a5edc"
 SRC_URI[sha256sum] = "d3468308553c94389dadfd10c4d1067269052b5364276a9d24a643c88485f715"
 
-inherit autotools update-alternatives
+inherit autotools
 
 EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'"
 
@@ -46,8 +46,6 @@ do_install_append_class-native () {
     install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk
 }
 
-ALTERNATIVE_${PN} = "pkg-config"
-
 # When using the RPM generated automatic package dependencies, some packages
 # will end up requiring 'pkgconfig(pkg-config)'.  Allow this behavior by
 # specifying an appropriate provide.