]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng-ust: Upgrade to 2.7 release
authorOtavio Salvador <otavio@ossystems.com.br>
Thu, 19 Nov 2015 15:48:33 +0000 (13:48 -0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Dec 2015 21:30:58 +0000 (21:30 +0000)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-kernel/lttng/lttng-ust/lttng-ust-Fix-live-timer-calculation-error.patch [deleted file]
meta/recipes-kernel/lttng/lttng-ust_git.bb

diff --git a/meta/recipes-kernel/lttng/lttng-ust/lttng-ust-Fix-live-timer-calculation-error.patch b/meta/recipes-kernel/lttng/lttng-ust/lttng-ust-Fix-live-timer-calculation-error.patch
deleted file mode 100644 (file)
index 03120fe..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From 6d02a6c1aeb1d050ffe7c6624bab9acfa76fc05f Mon Sep 17 00:00:00 2001
-From: Mikael Beckius <mikael.beckius@windriver.com>
-Date: Tue, 12 May 2015 11:04:34 +0200
-Subject: [PATCH] lttng-ust:Fix live timer calculation error
-
-There is an calculation error for live timer. Variable chan->switch_timer_interval is
-based on microsecond, and it is not right to assign chan->switch_timer_interval mod
-1000000 to var tv_nsec which is based on nanosecond.
-
-Upstream-Status: Pending
-
-Signed-off-by: Mikael Beckius <mikael.beckius@windriver.com>
-Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com>
----
- libringbuffer/ring_buffer_frontend.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libringbuffer/ring_buffer_frontend.c b/libringbuffer/ring_buffer_frontend.c
-index eb4e486..e0377a3 100644
---- a/libringbuffer/ring_buffer_frontend.c
-+++ b/libringbuffer/ring_buffer_frontend.c
-@@ -528,7 +528,7 @@ void lib_ring_buffer_channel_switch_timer_start(struct channel *chan)
-       }
-       its.it_value.tv_sec = chan->switch_timer_interval / 1000000;
--      its.it_value.tv_nsec = chan->switch_timer_interval % 1000000;
-+      its.it_value.tv_nsec = (chan->switch_timer_interval % 1000000) * 1000;
-       its.it_interval.tv_sec = its.it_value.tv_sec;
-       its.it_interval.tv_nsec = its.it_value.tv_nsec;
-@@ -582,7 +582,7 @@ void lib_ring_buffer_channel_read_timer_start(struct channel *chan)
-       }
-       its.it_value.tv_sec = chan->read_timer_interval / 1000000;
--      its.it_value.tv_nsec = chan->read_timer_interval % 1000000;
-+      its.it_value.tv_nsec = (chan->read_timer_interval % 1000000) * 1000;
-       its.it_interval.tv_sec = its.it_value.tv_sec;
-       its.it_interval.tv_nsec = its.it_value.tv_nsec;
--- 
-1.9.1
-
index ae4afd3d89fc93f8a1438eb71c5acd437f4e483a..1c08403a324b938c6aee7eca408a19269fe12bc7 100644 (file)
@@ -18,14 +18,12 @@ RPROVIDES_${PN} = "lttng2-ust"
 RREPLACES_${PN} = "lttng2-ust"
 RCONFLICTS_${PN} = "lttng2-ust"
 
-SRCREV = "c49ee9040ada6984c880756614e8a6f7fd645bd6"
+SRCREV = "826c6c686f16b9aeb3100f3f880d630911691cf1"
 PE = "2"
-PV = "2.6.2+git${SRCPV}"
+PV = "2.7.0+git${SRCPV}"
 
-SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.6 \
-           file://lttng-ust-doc-examples-disable.patch \
-           file://lttng-ust-Fix-live-timer-calculation-error.patch \
-        "
+SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.7 \
+           file://lttng-ust-doc-examples-disable.patch"
 
 S = "${WORKDIR}/git"