]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipetool: extend curl detection when creating recipes
authorRoss Burton <ross@burtonini.com>
Wed, 1 Dec 2021 15:42:32 +0000 (15:42 +0000)
committerAnuj Mittal <anuj.mittal@intel.com>
Tue, 7 Dec 2021 06:55:55 +0000 (14:55 +0800)
If a configure.ac uses LIBCURL_CHECK_CONFIG it wants curl.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 16e830ca1352cee61e4ae4b98b1203f849bf71f3)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
scripts/lib/recipetool/create_buildsys.py

index 35a97c93454e7d0c5b899c7cb03f8b0f2bd2007f..5015634476a14b41c534381a1d189c46c4f900bc 100644 (file)
@@ -545,7 +545,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
                 deps.append('zlib')
             elif keyword in ('AX_CHECK_OPENSSL', 'AX_LIB_CRYPTO'):
                 deps.append('openssl')
-            elif keyword == 'AX_LIB_CURL':
+            elif keyword in ('AX_LIB_CURL', 'LIBCURL_CHECK_CONFIG'):
                 deps.append('curl')
             elif keyword == 'AX_LIB_BEECRYPT':
                 deps.append('beecrypt')
@@ -624,6 +624,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
                     'AX_CHECK_OPENSSL',
                     'AX_LIB_CRYPTO',
                     'AX_LIB_CURL',
+                    'LIBCURL_CHECK_CONFIG',
                     'AX_LIB_BEECRYPT',
                     'AX_LIB_EXPAT',
                     'AX_LIB_GCRYPT',