]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: fix compatibility with glibc 2.27
authorTanu Kaskinen <tanuk@iki.fi>
Wed, 21 Mar 2018 17:09:16 +0000 (19:09 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Apr 2018 14:11:14 +0000 (15:11 +0100)
glibc 2.27 added function copy_file_range(), and e2fsprogs happens to
have a different function with the same name. The conflict made
e2fsprogs-native build fail.

Here's a backport of a fix from upstream, the fix was released in
e2fsprogs 1.43.8.

The master branch doesn't need this fix, since it has new enough
e2fsprogs version. At least rocko, pyro and morty need this, I haven't
checked older stable branches. Apparently the problematic function was
introduced in e2fsprogs version 1.43.

Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/e2fsprogs/e2fsprogs/0001-misc-rename-copy_file_range-to-copy_file_chunk.patch [new file with mode: 0644]
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.43.bb

diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs/0001-misc-rename-copy_file_range-to-copy_file_chunk.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs/0001-misc-rename-copy_file_range-to-copy_file_chunk.patch
new file mode 100644 (file)
index 0000000..276432c
--- /dev/null
@@ -0,0 +1,62 @@
+From 10e2247f7b4692e80d185bb65ea641585bdc6b4d Mon Sep 17 00:00:00 2001
+From: Palmer Dabbelt <palmer@dabbelt.com>
+Date: Fri, 29 Dec 2017 10:19:51 -0800
+Subject: [PATCH] misc: rename copy_file_range to copy_file_chunk
+
+As of 2.27, glibc will have a copy_file_range library call to wrap the
+new copy_file_range system call.  This conflicts with the function in
+misc/create_inode.c, which this patch renames _copy_file_range.
+
+Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
+Signed-off-by: Theodore Ts'o <tytso@mit.edu>
+
+Upstream-Status: Backport
+
+Signed-off-by: Tanu Kaskinen <tanuk@iki.fi>
+---
+ misc/create_inode.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/misc/create_inode.c b/misc/create_inode.c
+index c879a3ec..6acf0e20 100644
+--- a/misc/create_inode.c
++++ b/misc/create_inode.c
+@@ -392,7 +392,7 @@ static ssize_t my_pread(int fd, void *buf, size_t count, off_t offset)
+ }
+ #endif /* !defined HAVE_PREAD64 && !defined HAVE_PREAD */
+-static errcode_t copy_file_range(ext2_filsys fs, int fd, ext2_file_t e2_file,
++static errcode_t copy_file_chunk(ext2_filsys fs, int fd, ext2_file_t e2_file,
+                                off_t start, off_t end, char *buf,
+                                char *zerobuf)
+ {
+@@ -466,7 +466,7 @@ static errcode_t try_lseek_copy(ext2_filsys fs, int fd, struct stat *statbuf,
+               data_blk = data & ~(fs->blocksize - 1);
+               hole_blk = (hole + (fs->blocksize - 1)) & ~(fs->blocksize - 1);
+-              err = copy_file_range(fs, fd, e2_file, data_blk, hole_blk, buf,
++              err = copy_file_chunk(fs, fd, e2_file, data_blk, hole_blk, buf,
+                                     zerobuf);
+               if (err)
+                       return err;
+@@ -518,7 +518,7 @@ static errcode_t try_fiemap_copy(ext2_filsys fs, int fd, ext2_file_t e2_file,
+               }
+               for (i = 0, ext = ext_buf; i < fiemap_buf->fm_mapped_extents;
+                    i++, ext++) {
+-                      err = copy_file_range(fs, fd, e2_file, ext->fe_logical,
++                      err = copy_file_chunk(fs, fd, e2_file, ext->fe_logical,
+                                             ext->fe_logical + ext->fe_length,
+                                             buf, zerobuf);
+                       if (err)
+@@ -569,7 +569,7 @@ static errcode_t copy_file(ext2_filsys fs, int fd, struct stat *statbuf,
+       if (err != EXT2_ET_UNIMPLEMENTED)
+               goto out;
+-      err = copy_file_range(fs, fd, e2_file, 0, statbuf->st_size, buf,
++      err = copy_file_chunk(fs, fd, e2_file, 0, statbuf->st_size, buf,
+                             zerobuf);
+ out:
+       ext2fs_free_mem(&zerobuf);
+-- 
+2.16.2
+
index dcfb564a4b3d141ba81fd7aabd7434b351e6aca0..4eadc3eab4f313e2a7508a5b2608675a4b1cb512 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI += "file://acinclude.m4 \
             file://Revert-mke2fs-enable-the-metadata_csum-and-64bit-fea.patch \
             file://mkdir_p.patch \
             file://0001-e2fsck-exit-with-exit-status-0-if-no-errors-were-fix.patch \
+            file://0001-misc-rename-copy_file_range-to-copy_file_chunk.patch \
 "
 
 SRC_URI_append_class-native = " file://e2fsprogs-fix-missing-check-for-permission-denied.patch"