]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr-util: fix the rules.mk with path to sysroot instead of the workdir of apr
authorJackie Huang <jackie.huang@windriver.com>
Fri, 17 Aug 2012 03:11:43 +0000 (11:11 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 Aug 2012 12:10:04 +0000 (13:10 +0100)
The copying for rules.mk was happened in do_configure_prepend, but it will be
replaced by the one generated by configure, in which APR_MKEXPORT points to
the workdir of apr and cause compile filure when the workdir of apr is removed.
So change the copying in _prepend to _append.

[YOCTO #2947]

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/apr/apr-util_1.4.1.bb

index deb608f8dea04d2003b72881d00f6254893e9379..0516bc4accef0ef1e71ce4d4fd27236299d05de6 100644 (file)
@@ -32,8 +32,10 @@ inherit autotools lib_package binconfig
 
 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
 
-do_configure_prepend() {
-       cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+do_configure_append() {
+       if [ "${PN}" == "${BPN}" ]; then
+               cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+       fi
 }
 do_configure_prepend_virtclass-native() {
        cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk