]> code.ossystems Code Review - openembedded-core.git/commitdiff
ipkg-link: Drop
authorRichard Purdie <richard@openedhand.com>
Mon, 30 Jun 2008 11:37:12 +0000 (11:37 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 30 Jun 2008 11:37:12 +0000 (11:37 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4745 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch [deleted file]
meta/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb [deleted file]

diff --git a/meta/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch b/meta/packages/ipkg-utils/ipkg-link/link-vfat-libs.patch
deleted file mode 100644 (file)
index 7f495f9..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
---- ipkg-utils/ipkg-link.orig  2006-04-05 00:08:28.518992136 +0200
-+++ ipkg-utils/ipkg-link       2006-04-05 00:08:40.399186072 +0200
-@@ -58,6 +58,31 @@
-                               `ln -s "$PREFIX$line" "$line"`
-                       fi
-               fi
-+              
-+              # The next function checks whether the _source_ file (ie: /media/card/something)
-+              # does actually exist. If it doesn't, it could by a library symlink (ie: libsomething.0.1 -> libsomething.0)
-+              # Since VFAT & friends do not support symlinks, these library links would not exist after installation
-+              # and trying to symlink them into the rootfs with ipkg-link results in unconnected symlinks in the rootfs.
-+              # So we use the real lib file in /media/card/whatever and create all needed symlinks in the rootfs
-+              # using the real file as source.
-+                               
-+              if [ ! -e "$PREFIX$line" ]; then
-+                      if ( echo "$line" | grep -q "lib" ) ; then
-+                              libsearchfile=$(echo $line | sed -e "s#[a-z0-9/.]*/##g")
-+                              libfoundfiles=$(find $PREFIX -name "$libsearchfile*")
-+                      
-+                              for liblinkfile in $libfoundfiles; do
-+                                      echo "Linking $line to $liblinkfile"
-+                                      # link will be pointing to nowhere
-+                                      if test -L $line; then
-+                                              rm -f $line
-+                                      fi
-+                              ln -s $liblinkfile $line 
-+                            done
-+                      else
-+                              echo "WARNING: Source file [$PREFIX$line] is missing!"
-+                      fi
-+                fi
-       done
- }
diff --git a/meta/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb b/meta/packages/ipkg-utils/ipkg-link_1.6+cvs20050404.bb
deleted file mode 100644 (file)
index 35e5ba1..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-SECTION = "base"
-DESCRIPTION = "Itsy Package Manager utilities link script"
-LICENSE = "GPL"
-CONFLICTS = "ipkg-utils"
-SRCDATE = "20050404"
-PR = "r4"
-
-SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
-          file://link-vfat-libs.patch;patch=1"
-
-S = "${WORKDIR}/ipkg-utils"
-
-do_compile() {
-       :
-}
-
-do_install() {
-       install -d ${D}${bindir}
-       install -m 0755 ipkg-link ${D}${bindir}
-}