]> code.ossystems Code Review - openembedded-core.git/commitdiff
web-webkit: Add patch to configure for linking with g++ tweak else it breaks with...
authorRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 22:11:08 +0000 (22:11 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 22:11:08 +0000 (22:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4253 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/web/web-webkit/link-with-g++.patch
meta/packages/web/web-webkit_svn.bb

index 946d950cfd40e811c5fa46fecb2d1d63c9bbe9b8..50d6e937923315d549c588585a605579bb250cf4 100644 (file)
@@ -1,7 +1,8 @@
----
- src/Makefile.am |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+The main webkit library links against stdc++ so we need to use g++ for 
+linking. The easiest way to achieve this is to add a dummy cpp file.
+This also means we have to add AC_PROG_CXX else libtool 2.2.2 gets upset.
 
+RP - 14/4/08 
 --- webkit.orig/src/Makefile.am
 +++ webkit/src/Makefile.am
 @@ -1,11 +1,11 @@
  MAINTAINERCLEANFILES = config.h.in Makefile.in
  
  uidir = $(pkgdatadir)
+Index: webkit/configure.ac
+===================================================================
+--- webkit.orig/configure.ac   2008-04-14 22:15:25.000000000 +0100
++++ webkit/configure.ac        2008-04-14 22:16:31.000000000 +0100
+@@ -7,6 +7,7 @@
+ AC_ISC_POSIX
+ AC_PROG_CC
++AC_PROG_CXX
+ AC_STDC_HEADERS
+ AC_PROG_LIBTOOL
index e6789c880601c2b51a8ba3134ae2cdebb6d3d46d..75b3cf0cdf6886fd880c1eedf5cac5f4dca56545 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "x11"
 DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
 
 PV = "0.0+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
            file://link-with-g++.patch;patch=1"