]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: flag __SANE_USERSPACE_TYPES__ to include int-ll64.h for mips64
authorWenzong Fan <wenzong.fan@windriver.com>
Sat, 26 Oct 2013 07:53:16 +0000 (03:53 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 26 Oct 2013 14:59:50 +0000 (15:59 +0100)
As the same reason to powerpc64, mips64 also need the flag.

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index d27e535605d7a2a63eb6dcd78103495f150993b3..903ffa6eaff571939c8a79bd92b3a56fe95be952 100644 (file)
@@ -92,8 +92,9 @@ EXTRA_OEMAKE += "\
 # PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
 # prevents 64-bit userland from seeing this definition, instead defaulting
 # to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get 
-# int-ll64.h included.
+# int-ll64.h included. And MIPS64 has the same issue.
 EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
 
 PARALLEL_MAKE = ""