]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: Add relocation to rpm-native
authorMark Hatle <mark.hatle@windriver.com>
Tue, 1 Feb 2011 18:26:31 +0000 (12:26 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Feb 2011 23:59:42 +0000 (23:59 +0000)
[BUGID #668]

Use the create_wrapper to setup automatic run-time relocation of
rpm-native.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/rpm/rpm_5.4.0.bb

index 0f3425f794e6d20ec7f18397a097726379a38fbb..09d1fc0a62cc87c939418c7d64acd158d5ac6541 100644 (file)
@@ -43,7 +43,7 @@ LICENSE = "LGPL 2.1"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
 DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt"
-PR = "r9"
+PR = "r10"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -430,4 +430,30 @@ do_install_append() {
        rm -f ${D}/${libdir}/rpm/libsqldb.*
 }
 
+do_install_append_virtclass-native() {
+        create_wrapper ${D}/${bindir}/rpm \
+               RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+               RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+               RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
+
+        create_wrapper ${D}/${bindir}/rpm2cpio \
+               RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+               RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+               RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
+
+        create_wrapper ${D}/${bindir}/rpmbuild \
+               RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+               RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+               RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
+
+        create_wrapper ${D}/${bindir}/rpmconstant \
+               RPM_USRLIBRPM=${STAGING_LIBDIR_NATIVE}/rpm \
+               RPM_ETCRPM=${STAGING_ETCDIR_NATIVE}/rpm \
+               RPM_LOCALEDIRRPM=${STAGING_DATADIR_NATIVE}/locale
+
+       # Adjust popt macros to match...
+       cat ${D}/${libdir}/rpm/rpmpopt | sed -e "s,^\(rpm[^     ]*\)\([         ]\),\1.real\2," > ${D}/${libdir}/rpm/rpmpopt.new
+       mv ${D}/${libdir}/rpm/rpmpopt.new ${D}/${libdir}/rpm/rpmpopt
+}
+
 BBCLASSEXTEND = "native"