]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: stage headers
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 23 May 2008 14:10:46 +0000 (14:10 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 23 May 2008 14:10:46 +0000 (14:10 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4555 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/libtool/libtool-cross_2.2.4.bb
meta/packages/libtool/libtool_2.2.4.bb

index bbd1eaad80ceb0ee5e8184b605885db6f18526ca..1c3b13c5ce8565e0343c126cbccb2f72be507299 100644 (file)
@@ -1,7 +1,7 @@
 require libtool.inc
 require libtool_${PV}.bb
 
-PR = "r20"
+PR = "r21"
 PACKAGES = ""
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
 SRC_URI_append = " file://cross_compile.patch;patch=1 \
@@ -29,6 +29,8 @@ do_compile () {
 do_stage () {
        install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
        install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
+       install -d ${STAGING_INCDIR}/libltdl
+       install -m 0644 libltdl/libltdl/*.h ${STAGING_INCDIR}/libltdl/
        install -d ${STAGING_DATADIR}/libtool ${STAGING_DATADIR}/aclocal
        install -c ${S}/libltdl/config/config.guess ${STAGING_DATADIR}/libtool/
        install -c ${S}/libltdl/config/config.sub ${STAGING_DATADIR}/libtool/
index 95c8d176fb9167ec4852379b70067d128f2de797..fcaca4639b0a1fbd7d223050d016b13a7e5bf230 100644 (file)
@@ -1,6 +1,6 @@
 require libtool.inc
 
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
            file://dolt.m4"
@@ -17,6 +17,5 @@ inherit autotools
 EXTRA_AUTORECONF = "--exclude=libtoolize"
 
 do_stage () {
-       oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
-       install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
+       autotools_stage_all
 }