]> code.ossystems Code Review - openembedded-core.git/commitdiff
flex: upgrade from 2.5.31 to 2.5.35
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 21 Jun 2010 05:20:06 +0000 (22:20 -0700)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 1 Jul 2010 06:30:26 +0000 (23:30 -0700)
These patches removed from the recipe
 flex-lvalue.diff: already in the source
 fix-gen.patch: already in the source
 include.patch: already in the source

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/packages/flex/flex-2.5.31/include.patch [deleted file]
meta/packages/flex/flex.inc
meta/packages/flex/flex/fix-gen.patch [deleted file]
meta/packages/flex/flex/flex-lvalue.diff [deleted file]
meta/packages/flex/flex_2.5.31.bb [deleted file]
meta/packages/flex/flex_2.5.35.bb [new file with mode: 0644]

diff --git a/meta/packages/flex/flex-2.5.31/include.patch b/meta/packages/flex/flex-2.5.31/include.patch
deleted file mode 100644 (file)
index b60dcb2..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- flex-2.5.31/Makefile.am~include
-+++ flex-2.5.31/Makefile.am
-@@ -141,7 +141,7 @@
-       tests
- localedir = $(datadir)/locale
--AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
-+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
- LIBS = @LIBINTL@ @LIBS@
- skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
---- flex-2.5.31/Makefile.in~include
-+++ flex-2.5.31/Makefile.in
-@@ -292,7 +292,7 @@
- localedir = $(datadir)/locale
--AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
-+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
- # Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
- #
index d348d78cb102dc8fa5b179dc64fec373d97594b9..da95a5e25e5118f8d03c42d4ecd29163d3a0eefe 100644 (file)
@@ -5,9 +5,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 DEPENDS = "gettext"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-2.5.31.tar.bz2 \
-           file://flex-lvalue.diff;patch=1 \
-           file://fix-gen.patch;patch=1"
+SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 "
 
 inherit autotools
 
diff --git a/meta/packages/flex/flex/fix-gen.patch b/meta/packages/flex/flex/fix-gen.patch
deleted file mode 100644 (file)
index 55f4f6f..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- flex-2.5.31/gen.c~fix-gen
-+++ flex-2.5.31/gen.c
-@@ -1812,8 +1812,7 @@
-                       if (yytext_is_array) {
-                               if (!reentrant){
-                               indent_puts ("static int yy_more_offset = 0;");
--                }else{
--                    indent_puts ("static int yy_prev_more_offset = 0;");
-+                                indent_puts ("static int yy_prev_more_offset = 0;");
-                 }
-                       }
-                       else if (!reentrant) {
diff --git a/meta/packages/flex/flex/flex-lvalue.diff b/meta/packages/flex/flex/flex-lvalue.diff
deleted file mode 100644 (file)
index 56ae539..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-Patch from http://bugs.debian.org/cgi-bin/bugreport.cgi/flex-lvalue.diff?bug=194844;msg=10;att=1
-
-according to posix 0,1,2 are already setup and this avoids
-the issues with
-| filter.c: In function 'filter_apply_chain':
-| filter.c:161: error: invalid lvalue in assignment
-| filter.c:163: error: invalid lvalue in assignment
-| filter.c:184: error: invalid lvalue in assignment
-
-
-diff -ur flex-2.5.31.ORIG/filter.c flex-2.5.31/filter.c
---- flex-2.5.31.ORIG/filter.c  2003-03-25 16:39:08.000000000 +0000
-+++ flex-2.5.31/filter.c       2003-05-27 17:00:26.000000000 +0000
-@@ -157,11 +157,8 @@
-               if (chain->filter_func) {
-                       int     r;
--                      /* setup streams again */
--                      if ((stdin = fdopen (0, "r")) == NULL)
--                              flexfatal (_("fdopen(0) failed"));
--                      if ((stdout = fdopen (1, "w")) == NULL)
--                              flexfatal (_("fdopen(1) failed"));
-+                      /* POSIX says we inherit fd[0-2], so we don't need
-+                         to do anything to them here */
-                       if ((r = chain->filter_func (chain)) == -1)
-                               flexfatal (_("filter_func failed"));
-@@ -181,8 +178,6 @@
-       if (dup2 (pipes[1], 1) == -1)
-               flexfatal (_("dup2(pipes[1],1)"));
-       close (pipes[1]);
--      if ((stdout = fdopen (1, "w")) == NULL)
--              flexfatal (_("fdopen(1) failed"));
-       return true;
- }
diff --git a/meta/packages/flex/flex_2.5.31.bb b/meta/packages/flex/flex_2.5.31.bb
deleted file mode 100644 (file)
index 7ca7c7e..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-require flex.inc
-PR = "r5"
-
-SRC_URI += "file://include.patch;patch=1"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/packages/flex/flex_2.5.35.bb b/meta/packages/flex/flex_2.5.35.bb
new file mode 100644 (file)
index 0000000..f5f20f4
--- /dev/null
@@ -0,0 +1,4 @@
+require flex.inc
+PR = "r0"
+
+BBCLASSEXTEND = "native"