]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdk-pixbuf: use PACKAGECONFIG to control legacy X11 sub-library
authorRoss Burton <ross.burton@intel.com>
Mon, 21 Oct 2013 09:28:49 +0000 (10:28 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 26 Oct 2013 14:53:24 +0000 (15:53 +0100)
Instead of appending and using overrides, turn gdk-pixbuf-xlib into a
PACKAGECONFIG option and enable it for LSB-builds only.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.28.2.bb

index 08d6f0aedcf16dd821c50c71b38e9a1f581e26e1..d027fcf4f7fa28ad042b3a4c4e32cbf5cf8d660b 100644 (file)
@@ -26,15 +26,18 @@ inherit autotools pkgconfig gettext pixbufcache
 
 LIBV = "2.10.0"
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_linuxstdbase = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+PACKAGECONFIG_class-native = ""
+PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11"
+
 EXTRA_OECONF = "\
-  --without-libtiff \
   --with-libpng \
-  ${X11DEPENDS} \
+  --with-libjpeg \
+  --without-libtiff \
+  --without-libjasper \
   --disable-introspection \
 "
-X11DEPENDS = "--without-x11"
-X11DEPENDS_linuxstdbase = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x11', '--without-x11', d)}"
-X11DEPENDS_class-native = "--without-x11"
 
 PACKAGES =+ "${PN}-xlib"