]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: revise the RRECOMMENDS_perl-modules for multilib case
authorYu Ke <ke.yu@intel.com>
Sat, 16 Jul 2011 02:00:45 +0000 (10:00 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2011 14:24:56 +0000 (15:24 +0100)
current RRECOMMENDS_perl-modules replace the hardcode "perl-dbg",
"perl-misc" etc. which does not work in multilib case. Instead, it
should replace the "lib64-perl-dbg", "lib-64-perl-misc". without
doing this, current code will produce RRECOMMENDS=lib64-lib64-xxx etc

This patch revise the code to fix this issue

Signed-off-by: Yu Ke <ke.yu@intel.com>
Signed-off-by: Xu Dongxiao <dongxiao.xu@intel.com>
meta/recipes-devtools/perl/perl_5.12.3.bb

index c75a5322df269cde279724a47be12cc10aea1939..4b6b5a796b7c3031a83bcc59f2ef016ac2425f55 100644 (file)
@@ -282,7 +282,7 @@ FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
 # packages (actually the non modules packages and not created too)
 ALLOW_EMPTY_perl-modules = "1"
 PACKAGES_append = " perl-modules "
-RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('perl-modules ', '').replace('perl-dbg ', '').replace('perl-misc ', '').replace('perl-dev ', '').replace('perl-pod ', '').replace('perl-doc ', '')}"
+RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('${PN}-modules ', '').replace('${PN}-dbg ', '').replace('${PN}-misc ', '').replace('${PN}-dev ', '').replace('${PN}-pod ', '').replace('${PN}-doc ', '')}"
 
 python populate_packages_prepend () {
         libdir = bb.data.expand('${libdir}/perl/${PV}', d)