]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: account for HOSTCC and HOSTCXX
authorBruce Ashfield <bruce.ashfield@gmail.com>
Thu, 10 Sep 2020 02:04:10 +0000 (22:04 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 Sep 2020 16:07:05 +0000 (17:07 +0100)
Since commit 740d87766cb87f75c477 [kernel.bbclass: Configuration
for environment with HOSTCXX], both HOSTCC and HOSTCXX are pickedup
by the kernel build system as triggers to reconfigure if changed.

As with previous changes to devsrc, we replace the cross build
variant, with what will be on target, so operations such as
'make scripts prepare' won't trigger a reconfiguration.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/kernel-devsrc.bb

index a9c7be0f819288c84f97dc49f2d950668c15acf9..aa8e162f4ffcbd6c213930c853e45a6acd84a76f 100644 (file)
@@ -261,6 +261,8 @@ do_install() {
     if [ -e "$kerneldir/build/include/config/auto.conf.cmd" ]; then
         sed -i 's/ifneq "$(CC)" ".*-linux-.*gcc.*$/ifneq "$(CC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
         sed -i 's/ifneq "$(LD)" ".*-linux-.*ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
+        sed -i 's/ifneq "$(HOSTCXX)" ".*$/ifneq "$(HOSTCXX)" "g++"/' "$kerneldir/build/include/config/auto.conf.cmd"
+        sed -i 's/ifneq "$(HOSTCC)" ".*$/ifneq "$(HOSTCC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
         sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
         sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
         # we don't build against the defconfig, so make sure it isn't the trigger for syncconfig