]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston-init: start weston on a new VT
authorRoss Burton <ross.burton@intel.com>
Thu, 7 Nov 2013 11:55:35 +0000 (11:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 12 Dec 2013 16:53:05 +0000 (16:53 +0000)
Weston 1.3 needs to run on a VT, which is typically handled by weston-launch.
Currently weston-init doesn't use weston-launch as that depends on the
(non-default) pam DISTRO_FEATURE, so depend on kbd and use openvt directly.

This also fixes problems caused by the init script blocking until Weston exits,
which meant that later init scripts were not actually running.

(From OE-Core master rev: 3726eb29cfa79a4a1fbdbcaa96f770063c482858)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-graphics/wayland/weston-init.bb
meta/recipes-graphics/wayland/weston-init/init

index a3fe811f4d3be6ee5550fcf2e5c75dfec4d7845b..4ebda8b29775757947accff23867f9596ccaa2b6 100644 (file)
@@ -13,5 +13,7 @@ do_install() {
 
 inherit allarch update-rc.d
 
+RDEPENDS_${PN} = "weston kbd"
+
 INITSCRIPT_NAME = "weston"
 INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
index daa7f2300f00a3ec72a1221d4f8f2d594924be2f..284fd0ac3ceae1a488823a828018aa621d0310fa 100644 (file)
@@ -34,7 +34,7 @@ case "$1" in
                 chmod 0700 $XDG_RUNTIME_DIR
         fi
 
-        weston
+        openvt -s weston
   ;;
 
   stop)