]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-toolchain: Create task-poky-standalone-sdk-host and target tasks packages and...
authorRichard Purdie <richard@openedhand.com>
Thu, 28 Jun 2007 11:09:21 +0000 (11:09 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 28 Jun 2007 11:09:21 +0000 (11:09 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2038 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/meta/meta-toolchain.bb
meta/packages/tasks/task-poky-standalone-sdk-host.bb [new file with mode: 0644]
meta/packages/tasks/task-poky-standalone-sdk-target.bb [moved from meta/packages/tasks/task-sdk.bb with 63% similarity]

index 391adc4114b5a2dc9b71d20927bda5e5eadd37d3..652eb253712cf6c4e3a1d70ce2439e068f517fc4 100644 (file)
@@ -17,21 +17,9 @@ SDK_DEPLOY = "${TMPDIR}/deploy/sdk"
 IPKG_HOST = "ipkg-cl -f ${SDK_DIR}/ipkg-host.conf -o ${SDK_OUTPUT}"
 IPKG_TARGET = "ipkg-cl -f ${SDK_DIR}/ipkg-target.conf -o ${SDK_OUTPUT}/${prefix}"
 
-HOST_INSTALL = "\
-    binutils-cross-sdk \
-    gcc-cross-sdk \
-    g++ \
-    cpp \
-    libgcc \
-    libgcc-dev \
-    libstdc++ \
-    libstdc++-dev \
-    gdb-cross \
-    "
-
-TARGET_INSTALL = "\
-    task-sdk-bare \
-    "
+HOST_INSTALL = "task-poky-standalone-sdk-host"
+
+TARGET_INSTALL = "task-poky-standalone-sdk-target"
 
 RDEPENDS = "${TARGET_INSTALL} ${HOST_INSTALL}"
 
@@ -60,7 +48,7 @@ EOF
        mkdir -p ${SDK_OUTPUT}
 
        ${IPKG_HOST} update
-       ${IPKG_HOST} -nodeps install ${HOST_INSTALL}
+       ${IPKG_HOST} -force-depends install ${HOST_INSTALL}
 
        ${IPKG_TARGET} update
        ${IPKG_TARGET} install ${TARGET_INSTALL}
diff --git a/meta/packages/tasks/task-poky-standalone-sdk-host.bb b/meta/packages/tasks/task-poky-standalone-sdk-host.bb
new file mode 100644 (file)
index 0000000..2140e96
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Host packages for the standalone SDK (external toolchain)"
+PR = "r0"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+inherit sdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+    binutils-cross-sdk \
+    gcc-cross-sdk \
+    g++ \
+    cpp \
+    libgcc \
+    libgcc-dev \
+    libstdc++ \
+    libstdc++-dev \
+    gdb-cross \
+    "
\ No newline at end of file
similarity index 63%
rename from meta/packages/tasks/task-sdk.bb
rename to meta/packages/tasks/task-poky-standalone-sdk-target.bb
index 1f3c4a7411c17a773b86260ef079412efe884a81..6945715c4a6cf6393bdbe8bf0519469accaf5251 100644 (file)
@@ -1,13 +1,11 @@
-DESCRIPTION = "SDK packages"
-PR = "r16"
+DESCRIPTION = "Target packages for the standalone SDK (external toolchain)"
+PR = "r0"
 LICENSE = "MIT"
 ALLOW_EMPTY = "1"
 
-PACKAGES = "\
-    task-sdk-bare \
-    "
+PACKAGES = "${PN}"
 
-RDEPENDS_task-sdk-bare = "\
+RDEPENDS_${PN} = "\
     glibc \
     glibc-dev \
     glibc-utils \
@@ -22,7 +20,3 @@ RDEPENDS_task-sdk-bare = "\
     libgcc \
     libstdc++ \
     "
-
-RRECOMMENDS_task-sdk-bare = "\
-    glibc-binary-localedata-en-gb \
-    "
\ No newline at end of file