]> code.ossystems Code Review - openembedded-core.git/commitdiff
tiff: Security fix CVE-2016-9539
authorZhixiong Chi <zhixiong.chi@windriver.com>
Mon, 28 Nov 2016 09:52:13 +0000 (17:52 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 May 2017 12:13:38 +0000 (13:13 +0100)
tools/tiffcrop.c in libtiff 4.0.6 has an out-of-bounds read in
readContigTilesIntoBuffer(). Reported as MSVR 35092.

External References:
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-9539

Patch from:
https://github.com/vadz/libtiff/commit/ae9365db1b271b62b35ce018eac8799b1d5e8a53

(From OE-Core rev: 58bf0a237ca28459eb8c3afa030c0054f5bc1f16)

(From OE-Core rev: 0933a11707a369c8eaefebd31e8eea634084d66e)

Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-multimedia/libtiff/files/CVE-2016-9539.patch [new file with mode: 0644]
meta/recipes-multimedia/libtiff/tiff_4.0.6.bb

diff --git a/meta/recipes-multimedia/libtiff/files/CVE-2016-9539.patch b/meta/recipes-multimedia/libtiff/files/CVE-2016-9539.patch
new file mode 100644 (file)
index 0000000..1d9be42
--- /dev/null
@@ -0,0 +1,60 @@
+From ae9365db1b271b62b35ce018eac8799b1d5e8a53 Mon Sep 17 00:00:00 2001
+From: erouault <erouault>
+Date: Fri, 14 Oct 2016 19:13:20 +0000
+Subject: [PATCH ] * tools/tiffcrop.c: fix out-of-bound read of up to 3 bytes
+ in readContigTilesIntoBuffer(). Reported as MSVR 35092 by Axel Souchet
+ & Vishal Chauhan from the MSRC Vulnerabilities & Mitigations team.
+
+CVE: CVE-2016-9539
+
+Upstream-Status: Backport
+https://github.com/vadz/libtiff/commit/ae9365db1b271b62b35ce018eac8799b1d5e8a53
+
+Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com>
+
+---
+ ChangeLog        |  6 ++++++
+ tools/tiffcrop.c | 11 ++++++++++-
+ 2 files changed, 16 insertions(+), 1 deletion(-)
+
+Index: tiff-4.0.6/ChangeLog
+===================================================================
+--- tiff-4.0.6.orig/ChangeLog  2016-11-28 14:56:32.109283913 +0800
++++ tiff-4.0.6/ChangeLog       2016-11-28 16:36:01.805325534 +0800
+@@ -17,6 +17,12 @@
+       Fixes http://bugzilla.maptools.org/show_bug.cgi?id=2500
+       (CVE-2014-8127, duplicate: CVE-2016-3658)
++2016-10-14 Even Rouault <even.rouault at spatialys.com>
++
++      * tools/tiffcrop.c: fix out-of-bound read of up to 3 bytes in
++      readContigTilesIntoBuffer(). Reported as MSVR 35092 by Axel Souchet
++      & Vishal Chauhan from the MSRC Vulnerabilities & Mitigations team.
++
+ 2016-10-08 Even Rouault <even.rouault at spatialys.com>
+       * tools/tiffcp.c: fix out-of-bounds write on tiled images with odd
+Index: tiff-4.0.6/tools/tiffcrop.c
+===================================================================
+--- tiff-4.0.6.orig/tools/tiffcrop.c   2016-11-28 14:56:31.433283908 +0800
++++ tiff-4.0.6/tools/tiffcrop.c        2016-11-28 16:42:13.793328128 +0800
+@@ -819,9 +819,18 @@
+     }
+     }
+-  tilebuf = _TIFFmalloc(tile_buffsize);
++  /* Add 3 padding bytes for extractContigSamplesShifted32bits */
++  if( tile_buffsize > 0xFFFFFFFFU - 3 )
++  {
++      TIFFError("readContigTilesIntoBuffer", "Integer overflow when calculating buffer size.");
++      exit(-1);
++  }
++  tilebuf = _TIFFmalloc(tile_buffsize + 3);
+   if (tilebuf == 0)
+     return 0;
++  tilebuf[tile_buffsize] = 0;
++  tilebuf[tile_buffsize+1] = 0;
++  tilebuf[tile_buffsize+2] = 0;
+   dst_rowsize = ((imagewidth * bps * spp) + 7) / 8;  
+   for (row = 0; row < imagelength; row += tl)
index 3057121e7c3005119ad7ecfb4dd47d6620b75ddc..3a7906a98dd3e965d26e74ee6b1f61c7995af9bb 100644 (file)
@@ -18,6 +18,7 @@ SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
            file://CVE-2016-3658.patch \
            file://CVE-2016-3632.patch \
            file://CVE-2016-9540.patch \
+           file://CVE-2016-9539.patch \
           "
 
 SRC_URI[md5sum] = "d1d2e940dea0b5ad435f21f03d96dd72"