]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: Fix inotify ARM syscall issue, removing boot time warning
authorRichard Purdie <richard@openedhand.com>
Wed, 26 Jul 2006 21:26:34 +0000 (21:26 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 26 Jul 2006 21:26:34 +0000 (21:26 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@555 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/udev/udev-092/arm_inotify_fix.patch [new file with mode: 0644]
meta/packages/udev/udev_092.bb

diff --git a/meta/packages/udev/udev-092/arm_inotify_fix.patch b/meta/packages/udev/udev-092/arm_inotify_fix.patch
new file mode 100644 (file)
index 0000000..4bd0d4d
--- /dev/null
@@ -0,0 +1,17 @@
+Index: udev-092/udev_libc_wrapper.h
+===================================================================
+--- udev-092.orig/udev_libc_wrapper.h  2006-07-26 21:55:06.000000000 +0100
++++ udev-092/udev_libc_wrapper.h       2006-07-26 21:55:37.000000000 +0100
+@@ -58,9 +58,9 @@
+ # define __NR_inotify_add_watch       152
+ # define __NR_inotify_rm_watch        156
+ #elif defined (__arm__)
+-# define __NR_inotify_init    316
+-# define __NR_inotify_add_watch       317
+-# define __NR_inotify_rm_watch        318
++# define __NR_inotify_init    __NR_SYSCALL_BASE+316
++# define __NR_inotify_add_watch       __NR_SYSCALL_BASE+317
++# define __NR_inotify_rm_watch        __NR_SYSCALL_BASE+318
+ #elif defined (__sh__)
+ # define __NR_inotify_init    290
+ # define __NR_inotify_add_watch       291
index f25eeb09461c1ab0ca183c1595199d047b443e8b..4badbfc075ef36fe68a5429534b720ba7881d6f8 100644 (file)
@@ -3,12 +3,13 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES = "hotplug"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \
           file://flags.patch;patch=1 \
           file://udevsynthesize.patch;patch=1 \
+           file://arm_inotify_fix.patch;patch=1 \
           file://udevsynthesize.sh \
           file://mount.blacklist"