]> code.ossystems Code Review - openembedded-core.git/commitdiff
logrotate: Identify CONFFILES
authorRob Woolley <rob.woolley@windriver.com>
Mon, 9 Mar 2015 23:52:58 +0000 (19:52 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Mar 2015 17:38:46 +0000 (17:38 +0000)
Some package formats explicitly track which files are configuration files
so that they are not overwritten on updates. We must use an explicit list
instead of a wildcard as logrotate also provides files under ${sysconfdir}
that are not configuration files.

Signed-off by: Rob Woolley <rob.woolley@windriver.com>

meta/recipes-extended/logrotate/logrotate_3.8.8.bb

index 00432dede267c7c2a90564f8f0029964610941bc..e3cfa90ced04334a037ccdfc6bc6f69295e0be29 100644 (file)
@@ -27,6 +27,9 @@ PACKAGECONFIG ?= "\
 PACKAGECONFIG[acl] = ",,acl"
 PACKAGECONFIG[selinux] = ",,libselinux"
 
+CONFFILES_${PN} += "${localstatedir}/lib/logrotate.status \
+                   ${sysconfdir}/logrotate.conf"
+
 # If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
 # optimization variables, so use it rather than EXTRA_CFLAGS.
 EXTRA_OEMAKE = "\