]> code.ossystems Code Review - openembedded-core.git/commitdiff
ruby: Security fix for CVE-2017-9227
authorThiruvadi Rajaraman <trajaraman@mvista.com>
Sat, 4 Nov 2017 17:35:54 +0000 (10:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Nov 2017 14:42:57 +0000 (14:42 +0000)
affects ruby < 2.4.1

Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com>
Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch [new file with mode: 0644]
meta/recipes-devtools/ruby/ruby_2.2.5.bb

diff --git a/meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch b/meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch
new file mode 100644 (file)
index 0000000..f6eaefb
--- /dev/null
@@ -0,0 +1,24 @@
+commit 9690d3ab1f9bcd2db8cbe1fe3ee4a5da606b8814
+Author: K.Kosako <kosako@sofnec.co.jp>
+Date:   Tue May 23 16:15:35 2017 +0900
+
+    fix #58 : access to invalid address by reg->dmin value
+
+Upstream-Status: backport
+
+CVE: CVE-2017-9227
+Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com>
+
+Index: ruby-2.2.5/regexec.c
+===================================================================
+--- ruby-2.2.5.orig/regexec.c  2014-09-15 21:48:41.000000000 +0530
++++ ruby-2.2.5/regexec.c       2017-08-30 12:18:04.054828426 +0530
+@@ -3678,6 +3678,8 @@
+     }
+     else {
+       UChar *q = p + reg->dmin;
++
++      if (q >= end) return 0; /* fail */
+       while (p < q) p += enclen(reg->enc, p, end);
+     }
+   }
index 35882d18e61cac8b9a3fca4eb495d528364eef5a..e29eb9c9b46d1239cc01dfd5b19008a09dd21cd0 100644 (file)
@@ -5,6 +5,7 @@ SRC_URI[sha256sum] = "30c4b31697a4ca4ea0c8db8ad30cf45e6690a0f09687e5d483c933c03c
 
 SRC_URI += "file://prevent-gc.patch \
             file://CVE-2016-7798.patch \
+            file://CVE-2017-9227.patch \
 "
 
 # it's unknown to configure script, but then passed to extconf.rb