]> code.ossystems Code Review - openembedded-core.git/commitdiff
telepathy-python: avoid duplicated installation of errors.py
authorDongxiao Xu <dongxiao.xu@intel.com>
Wed, 7 Sep 2011 08:18:06 +0000 (16:18 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Sep 2011 21:28:40 +0000 (22:28 +0100)
telepathy-python install fails on latest Fedora 16 due to the tighter
check of duplicated file installation.

Remove one errors.py entry in Makefile.am to fix this issue.

[YOCTO #1453]

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch [new file with mode: 0644]
meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb

diff --git a/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch b/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch
new file mode 100644 (file)
index 0000000..df95a4c
--- /dev/null
@@ -0,0 +1,26 @@
+commit f6c67662145de889055a86a6b3b12c70a45fc8d5
+Author: Dongxiao Xu <dongxiao.xu@intel.com>
+Date:   Wed Sep 7 16:02:20 2011 +0800
+
+    Avoid duplicated installation of errors.py
+    
+    newer version of autotools don't seem to like listing files to install
+    twice. Remove one errors.py from the installation list.
+    
+    Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+    
+    Upstream-Status: Inappropirate [upstream inactive]
+    
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 5c27dfe..7536e43 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -11,7 +11,7 @@ telepathy_PYTHON = \
+ # telepathy._generated.* auto-generated modules
+ spec_dir = $(top_srcdir)/spec
+-spec_files := $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml))
++spec_files := $(filter-out _generated/errors.py, $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml)))
+ BUILT_SOURCES = \
+       _generated/interfaces.py \
index ead8dea05b2f81586b714cf6973732f59212f205..817b911eae02a38e4b92e31a14b0a094cca3752d 100644 (file)
@@ -7,9 +7,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
 RDEPENDS_${PN} += "python-dbus"
 
 SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
-           file://parallel_make.patch"
+           file://parallel_make.patch \
+           file://remove_duplicate_install.patch"
 
-PR = "r2"
+PR = "r3"
 
 inherit autotools