]> code.ossystems Code Review - openembedded-core.git/commitdiff
sato-icon-theme: add more compatibility symlinks
authorRoss Burton <ross.burton@intel.com>
Fri, 27 Sep 2013 16:41:17 +0000 (16:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Sep 2013 21:01:32 +0000 (22:01 +0100)
libfm uses "preferences-desktop", so link it to the close-enough
"preferences-sytem".

x11vnc uses "computer", link it to "terminal".

pcmanfm uses "system-file-manager", link it to "file-manager".

[ YOCTO #4062 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb

index cb3b68c16e1c71e76f2d5dc0d53804906a278161..cf23aebf5e2b72353d8918ad9f24c6f1c98381e0 100644 (file)
@@ -23,6 +23,12 @@ FILES_${PN} += "${datadir}"
 
 EXTRA_OECONF += "--with-iconmap=${@d.getVar('STAGING_LIBEXECDIR_NATIVE', True).replace('sato-icon-theme', 'icon-naming-utils')}/icon-name-mapping"
 
+do_install_append() {
+       find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \;
+       find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \;
+       find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \;
+}
+
 # Explictly setting "Sato" as the default icon theme to avoid flickering from
 # the desktop and settings daemon racing.  This shouldn't be done here but in the sato image
 pkg_postinst_${PN} () {