]> code.ossystems Code Review - openembedded-core.git/commitdiff
clutter: Refresh patch
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 21 Apr 2009 16:48:32 +0000 (17:48 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 21 Apr 2009 16:48:32 +0000 (17:48 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/clutter/clutter/enable_tests.patch

index 8544614790a8f69c77321674726ad35a6511f7f4..953edf6bbc3c514c40161214190dd66b56068aff 100644 (file)
@@ -6,10 +6,10 @@
 
 Index: git/tests/interactive/Makefile.am
 ===================================================================
---- git.orig/tests/interactive/Makefile.am     2008-12-18 16:50:45.000000000 +0000
-+++ git/tests/interactive/Makefile.am  2008-12-18 16:57:36.000000000 +0000
-@@ -68,7 +68,7 @@
- AM_CFLAGS = $(CLUTTER_CFLAGS)
+--- git.orig/tests/interactive/Makefile.am     2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/Makefile.am  2009-03-12 11:04:12.000000000 +0000
+@@ -77,7 +77,7 @@
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(MAINTAINER_CFLAGS)
  AM_LDFLAGS = $(CLUTTER_LIBS)
  
 -noinst_PROGRAMS = test-interactive
@@ -19,14 +19,14 @@ Index: git/tests/interactive/Makefile.am
        test-main.c \
 Index: git/tests/interactive/test-actors.c
 ===================================================================
---- git.orig/tests/interactive/test-actors.c   2008-12-18 16:58:06.000000000 +0000
-+++ git/tests/interactive/test-actors.c        2008-12-18 16:58:13.000000000 +0000
-@@ -189,7 +189,7 @@
-       /* Create a texture from file, then clone in to same resources */
-       if (i == 0)
-       {
--        if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
-+        if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
-                                                           &error)) == NULL)
-           {
-             g_error ("image load failed: %s", error->message);
+--- git.orig/tests/interactive/test-actors.c   2009-03-12 11:01:36.000000000 +0000
++++ git/tests/interactive/test-actors.c        2009-03-12 11:06:32.000000000 +0000
+@@ -182,7 +182,7 @@
+   oh->scaler_1 = clutter_behaviour_scale_new (alpha, 0.5, 0.5, 1.0, 1.0);
+   oh->scaler_2 = clutter_behaviour_scale_new (alpha, 1.0, 1.0, 0.5, 0.5);
+-  real_hand = clutter_texture_new_from_file ("redhand.png", &error);
++  real_hand = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", &error);
+   if (real_hand == NULL)
+     {
+       g_error ("image load failed: %s", error->message);