]> code.ossystems Code Review - openembedded-core.git/commitdiff
sha-native: Update staging function
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 21:53:21 +0000 (21:53 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 21:53:21 +0000 (21:53 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/shasum/shasum-native.bb
meta/packages/shasum/shasum.inc

index a28d5ac967a995ee71859f837ca3410b2e7235f6..d39a6c3865de93e4175aae208e08969ed3b1a16c 100644 (file)
@@ -6,7 +6,3 @@ INHIBIT_DEFAULT_DEPS = "1"
 PATCHTOOL = "patch"
 
 do_fetch[depends] = ""
-do_stage() {
-    install -d ${STAGING_BINDIR}
-    install ${S}/oe_sha256sum ${STAGING_BINDIR}
-}
index 343a2d288e9626cde382276062b15aa65a138731..ad51bcc608da3c3407f4ccfc447cb36ddf469249 100644 (file)
@@ -1,20 +1,24 @@
 SUMMARY = "A simple tool to create sha256 hashes from a file"
 LICENSE = "LGPL"
 
-PR      = "r1"
+PR = "r1"
 
 S = "${WORKDIR}"
 
-
 SRC_URI = "file://main.c         \
            file://mhash_sha256.h \
            file://sha256.c "
 
-
 do_configure() {
-    :
+       :
 }
 
 do_compile() {
-    $CC $CFLAGS $CPPFLAGS -o oe_sha256sum main.c sha256.c
+       $CC $CFLAGS $CPPFLAGS -o oe_sha256sum main.c sha256.c
+}
+
+NATIVE_INSTALL_WORKS = "1"
+do_install() {
+       install -d ${D}${bindir}/
+       install ${S}/oe_sha256sum ${D}${bindir}/
 }