]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: fix ptest execution failure
authorChong Lu <Chong.Lu@windriver.com>
Mon, 18 Aug 2014 05:19:22 +0000 (13:19 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Aug 2014 08:25:07 +0000 (09:25 +0100)
ptest needs runtest-TESTS target.
serial-tests is required to generate this target.

Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch

index f5556b23e30ec4e3af59b645c1ffc3b487b39d0a..3a0eb3937595cb2cb570d1df5e075144e16c5ae7 100644 (file)
@@ -1,11 +1,13 @@
 strace: Add ptest
 
+Upstream-Status: Inappropriate
+
 Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
-Upstream-Status: Pending
+Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
 
 --- old/tests/Makefile.am      2013-07-23 13:44:24.660481381 +0200
 +++ new/tests/Makefile.am      2013-07-23 16:22:42.937654391 +0200
-@@ -9,3 +9,20 @@
+@@ -9,3 +9,21 @@
  EXTRA_DIST = init.sh $(TESTS)
  
  CLEANFILES = check.log
@@ -18,6 +20,7 @@ Upstream-Status: Pending
 +      install -d $(DESTDIR)/$(TESTDIR)
 +      cp $(BUILDDIR)/$(TESTDIR)/Makefile $(DESTDIR)/$(TESTDIR)
 +      sed -i -e 's/^Makefile:/_Makefile:/' $(DESTDIR)/$(TESTDIR)/Makefile
++      sed -i -e 's/bash/sh/' $(DESTDIR)/$(TESTDIR)/Makefile
 +      for file in $(check_PROGRAMS); do \
 +              install $(BUILDDIR)/$(TESTDIR)/$$file $(DESTDIR)/$(TESTDIR); \
 +      done
@@ -26,3 +29,13 @@ Upstream-Status: Pending
 +              sed -i -e 's/$${srcdir=.}/./g' $(DESTDIR)/$(TESTDIR)/$$file; \
 +      done
 +      sed -i -e 's/$$srcdir/./g' $(DESTDIR)/$(TESTDIR)/net
+--- a/configure.ac
++++ b/configure.ac
+@@ -6,7 +6,7 @@ AC_INIT([strace],
+ AC_CONFIG_SRCDIR([strace.c])
+ AC_CONFIG_AUX_DIR([.])
+ AC_CONFIG_HEADERS([config.h])
+-AM_INIT_AUTOMAKE([foreign dist-xz no-dist-gzip silent-rules])
++AM_INIT_AUTOMAKE([foreign dist-xz no-dist-gzip silent-rules serial-tests])
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST