]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-perl: Add libxml-perl
authorJingdong Lu <jingdong.lu@windriver.com>
Wed, 24 Nov 2010 04:37:58 +0000 (12:37 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 10 Dec 2010 23:13:00 +0000 (23:13 +0000)
Add libxml-perl in order to enable graphic LSB test(OLVER-Core test).

[sgw@linux.intel.com: fixed LICENSE]
Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/perl/libxml-perl_0.08.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
new file mode 100644 (file)
index 0000000..04a78e3
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
+documents for working with XML in Perl.  libxml-perl software \
+works in combination with XML::Parser, PerlSAX, XML::DOM, \
+XML::Grove and others."
+SUMMARY = "Collection of Perl modules for working with XML."
+SECTION = "libs"
+LICENSE = "Artistic | GPLv1+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
+
+DEPENDS += "libxml-parser-perl"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/${PN}-${PV}.tar.gz"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+
+do_compile() {
+       export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+       cpan_do_compile
+}
+